summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMiguel Jacq <mig@mig5.net>2018-05-02 14:41:15 +1000
committerMiguel Jacq <mig@mig5.net>2018-05-02 14:41:15 +1000
commit97d42492e5276357a846a1453ac2476901ffacc7 (patch)
treef9a16ea71ad9c0f1995277df9cd8e1ed01719810 /setup.py
parent7e777da27c79deaf3a3d29a1a02ae3e9b6042354 (diff)
downloadonionshare-97d42492e5276357a846a1453ac2476901ffacc7.tar.gz
onionshare-97d42492e5276357a846a1453ac2476901ffacc7.zip
Fix python setup process for share/static dir contents
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 99222ef0..460eb476 100644
--- a/setup.py
+++ b/setup.py
@@ -53,7 +53,9 @@ data_files=[
(os.path.join(sys.prefix, 'share/onionshare/images'), file_list('share/images')),
(os.path.join(sys.prefix, 'share/onionshare/locale'), file_list('share/locale')),
(os.path.join(sys.prefix, 'share/onionshare/templates'), file_list('share/templates')),
- (os.path.join(sys.prefix, 'share/onionshare/static'), file_list('share/static'))
+ (os.path.join(sys.prefix, 'share/onionshare/static/css'), file_list('share/static/css')),
+ (os.path.join(sys.prefix, 'share/onionshare/static/img'), file_list('share/static/img')),
+ (os.path.join(sys.prefix, 'share/onionshare/static/js'), file_list('share/static/js'))
]
if platform.system() != 'OpenBSD':
data_files.append(('/usr/share/nautilus-python/extensions/', ['install/scripts/onionshare-nautilus.py']))