summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Waldmann <tw@waldmann-edv.de>2014-11-18 18:59:48 +0100
committerThomas Waldmann <tw@waldmann-edv.de>2014-11-18 18:59:48 +0100
commit087102bde4ba857b261da269855151ae4beda3a1 (patch)
tree38653342d3e909630e38e552c297d88825ebaf04 /setup.py
parentf5889d96dd49f821bcba6d9416451881c6814d92 (diff)
downloadonionshare-087102bde4ba857b261da269855151ae4beda3a1.tar.gz
onionshare-087102bde4ba857b261da269855151ae4beda3a1.zip
pep8: too long lines, reformat lines to < 120 chars. removed redundancy from long_description in setup.py.
note: pep8 usually recommends 80 chars, but I find that impractical and unnecessary - it's not 1980 any more when code was edited on 80x25 terminals. i was a bit wondering about onionshare-launcher.py - it does a lot of imports, but does not use the imported names.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 14 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 1ef27ccc..6e797197 100644
--- a/setup.py
+++ b/setup.py
@@ -38,11 +38,23 @@ def file_list(path):
version = open('version').read().strip()
+description = (
+ """OnionShare lets you securely and anonymously share a file of any size with someone. """
+ """It works by starting a web server, making it accessible as a Tor hidden service, """
+ """and generating an unguessable URL to access and download the file.""")
+
+long_description = description + " " + (
+ """It doesn't require setting up a server on the internet somewhere or using a third """
+ """party filesharing service. You host the file on your own computer and use a Tor """
+ """hidden service to make it temporarily accessible over the internet. The other user """
+ """just needs to use Tor Browser to download the file from you."""
+)
+
setup(
name='onionshare',
version=version,
- description='OnionShare lets you securely and anonymously share a file of any size with someone. It works by starting a web server, making it accessible as a Tor hidden service, and generating an unguessable URL to access and download the file.',
- long_description="""OnionShare lets you securely and anonymously share a file of any size with someone. It works by starting a web server, making it accessible as a Tor hidden service, and generating an unguessable URL to access and download the file. It doesn't require setting up a server on the internet somewhere or using a third party filesharing service. You host the file on your own computer and use a Tor hidden service to make it temporarily accessible over the internet. The other user just needs to use Tor Browser to download the file from you.""",
+ description=description,
+ long_description=long_description,
author='Micah Lee',
author_email='micah@micahflee.com',
url='https://github.com/micahflee/onionshare',