summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2016-02-15 22:16:09 -0800
committerMicah Lee <micah@micahflee.com>2016-02-15 22:16:09 -0800
commitd438e25b9b6e1993a8839ef811b2e2533c17bf40 (patch)
tree4dcaa3171ea66967497c721efd541f91adce43ba /setup.py
parentd1c36fa04f82079def2e7cf36c13f259df8b7df2 (diff)
downloadonionshare-d438e25b9b6e1993a8839ef811b2e2533c17bf40.tar.gz
onionshare-d438e25b9b6e1993a8839ef811b2e2533c17bf40.zip
Successfully builds a .exe with Python3/Qt5. Switched from pyinstaller to py2exe. (#261)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9ad89b47..957b929d 100644
--- a/setup.py
+++ b/setup.py
@@ -121,3 +121,28 @@ elif system == 'Darwin':
},
setup_requires=['py2app', 'flask', 'stem'],
)
+
+elif system == 'Windows':
+ import py2exe
+ setup(
+ name='OnionShare',
+ version=version,
+ description=description,
+ long_description=long_description,
+ data_files=[
+ ('images', images),
+ ('locale', locale),
+ ('html', ['onionshare/index.html', 'onionshare/404.html']),
+ ('', ['version', 'install/license.txt', 'install/onionshare.ico']),
+ ('platforms', ['C:\\Python34\\Lib\\site-packages\\PyQt5\\plugins\\platforms\\qwindows.dll'])
+ ],
+ windows=['install/windows_scripts/onionshare.py'],
+ options={
+ 'py2exe': {
+ 'includes': [
+ 'PyQt5', 'PyQt5.QtCore', 'PyQt5.QtGui', 'PyQt5.QtWidgets',
+ 'jinja2', 'jinja2.ext', 'sip']
+ }
+ },
+ setup_requires=['py2exe', 'flask', 'stem'],
+ )