summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2018-03-06 02:54:12 -0800
committerMicah Lee <micah@micahflee.com>2018-03-06 02:54:12 -0800
commitce852fc60a3c4d7a0b826d3f01da9fcd00302b93 (patch)
tree5f737331d6725ab6eb4f1241c7ae30c039b11865 /setup.py
parentbaede536321431d5a19a2bb3ae659e875c2d9c63 (diff)
downloadonionshare-ce852fc60a3c4d7a0b826d3f01da9fcd00302b93.tar.gz
onionshare-ce852fc60a3c4d7a0b826d3f01da9fcd00302b93.zip
Create separate templates and static folder, and make the web app use both of these. Yay, now we have real static resources
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 23e1ea17..99222ef0 100644
--- a/setup.py
+++ b/setup.py
@@ -52,7 +52,8 @@ data_files=[
(os.path.join(sys.prefix, 'share/onionshare'), file_list('share')),
(os.path.join(sys.prefix, 'share/onionshare/images'), file_list('share/images')),
(os.path.join(sys.prefix, 'share/onionshare/locale'), file_list('share/locale')),
- (os.path.join(sys.prefix, 'share/onionshare/html'), file_list('share/html')),
+ (os.path.join(sys.prefix, 'share/onionshare/templates'), file_list('share/templates')),
+ (os.path.join(sys.prefix, 'share/onionshare/static'), file_list('share/static'))
]
if platform.system() != 'OpenBSD':
data_files.append(('/usr/share/nautilus-python/extensions/', ['install/scripts/onionshare-nautilus.py']))