summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2014-08-20 20:20:17 +0000
committerMicah Lee <micah@micahflee.com>2014-08-20 20:20:17 +0000
commitbbbf005dacab375a3f853cc091d892cb980c6f9f (patch)
tree67cff8f9f03e15a6e37554f966f1803bc0c74e21 /setup.py
parent7f9185f2669f096e149197058ca5d7ae592e11f5 (diff)
downloadonionshare-bbbf005dacab375a3f853cc091d892cb980c6f9f.tar.gz
onionshare-bbbf005dacab375a3f853cc091d892cb980c6f9f.zip
move constant_time_compare function into onionshare from itsdangerous, to avoid dependency problem
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 0 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 80a76745..492e7ac4 100644
--- a/setup.py
+++ b/setup.py
@@ -18,12 +18,6 @@ def file_list(path):
packages = ['onionshare', 'onionshare_gui']
-sys.path.remove(os.getcwd())
-try:
- import itsdangerous
-except ImportError:
- packages.append('itsdangerous')
-
version = open('version').read().strip()
setup(