summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2020-03-22 12:33:35 -0700
committerMicah Lee <micah@micahflee.com>2020-03-22 12:33:35 -0700
commit3c6e0cbda10bed2f6a2a604c4421a7bdf3cdf4eb (patch)
tree8ac4ab66002897c22eea1685046d2b7b3a8e6f22 /pyproject.toml
parent5c4e4ce10bd90ce103afaddfda1a625b8df8e062 (diff)
downloadonionshare-3c6e0cbda10bed2f6a2a604c4421a7bdf3cdf4eb.tar.gz
onionshare-3c6e0cbda10bed2f6a2a604c4421a7bdf3cdf4eb.zip
Change python version to ^3.7, and use PyQt 5.14 instead of the very latest. Run tests from poetry
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f72da02f..53ce5858 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,7 +6,7 @@ authors = ["Micah Lee <micah@micahflee.com>"]
license = "GPLv3+"
[tool.poetry.dependencies]
-python = "*"
+python = "^3.7"
altgraph = "*"
certifi = "*"
chardet = "*"
@@ -21,7 +21,7 @@ macholib = "*"
MarkupSafe = "*"
pefile = "*"
pycryptodome = "*"
-PyQt5 = "*"
+PyQt5 = "5.14"
PyQt5-sip = "*"
PySocks = "*"
requests = "*"