aboutsummaryrefslogtreecommitdiff
path: root/desktop/setup.py
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2021-12-21 14:16:10 -0800
committerMicah Lee <micah@micahflee.com>2021-12-21 14:16:10 -0800
commitf0d40beb77a9c27176077c0e42991f156930a63e (patch)
tree2eb82a887a1bb31906c5ca83759ddb5486cf7193 /desktop/setup.py
parentf4fb212dbc7d0a027080c5f8c325c32ee2362072 (diff)
downloadonionshare-f0d40beb77a9c27176077c0e42991f156930a63e.tar.gz
onionshare-f0d40beb77a9c27176077c0e42991f156930a63e.zip
Start implementing cx_Freeze
Diffstat (limited to 'desktop/setup.py')
-rw-r--r--desktop/setup.py30
1 files changed, 4 insertions, 26 deletions
diff --git a/desktop/setup.py b/desktop/setup.py
index 95cad942..3052e25e 100644
--- a/desktop/setup.py
+++ b/desktop/setup.py
@@ -1,36 +1,14 @@
#!/usr/bin/env python3
-# -*- coding: utf-8 -*-
-"""
-OnionShare | https://onionshare.org/
-
-Copyright (C) 2014-2021 Micah Lee, et al. <micah@micahflee.com>
-
-This program is free software: you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published by
-the Free Software Foundation, either version 3 of the License, or
-(at your option) any later version.
-
-This program is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with this program. If not, see <http://www.gnu.org/licenses/>.
-"""
import setuptools
+import os
-version = "2.4"
+with open(os.path.join("..", "cli", "onionshare_cli", "resources", "version.txt")) as f:
+ version = f.read().strip()
setuptools.setup(
name="onionshare",
version=version,
- description=(
- "OnionShare lets you securely and anonymously send and receive files. It works by starting a web "
- "server, making it accessible as a Tor onion service, and generating an unguessable web address so "
- "others can download files from you, or upload files to you. It does _not_ require setting up a "
- "separate server or using a third party file-sharing service."
- ),
+ description="Securely and anonymously share files, host websites, and chat with friends using the Tor network",
author="Micah Lee",
author_email="micah@micahflee.com",
maintainer="Micah Lee",