aboutsummaryrefslogtreecommitdiff
path: root/desktop/pyproject.toml
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2020-10-13 17:28:54 -0700
committerMicah Lee <micah@micahflee.com>2020-10-13 17:28:54 -0700
commitb42f92d714145dcc6282773e61f68c00b4b79a28 (patch)
treeee4443ab3c5300db279a3cf0686380074d98c973 /desktop/pyproject.toml
parentf4abcf1be9122a28005dc3e0949bf5952192e982 (diff)
downloadonionshare-b42f92d714145dcc6282773e61f68c00b4b79a28.tar.gz
onionshare-b42f92d714145dcc6282773e61f68c00b4b79a28.zip
Move docs back to root, move onionshare_gui into briefcase app, and make modifications so briefcase app will work
Diffstat (limited to 'desktop/pyproject.toml')
-rw-r--r--desktop/pyproject.toml21
1 files changed, 9 insertions, 12 deletions
diff --git a/desktop/pyproject.toml b/desktop/pyproject.toml
index 79ae4a43..0dcaa5e6 100644
--- a/desktop/pyproject.toml
+++ b/desktop/pyproject.toml
@@ -7,12 +7,13 @@ license = "GPLv3"
author = 'Micah Lee'
author_email = "micah@micahflee.com"
-[tool.briefcase.app.helloworld]
+[tool.briefcase.app.onionshare]
formal_name = "OnionShare"
description = "OnionShare lets you securely and anonymously send and receive files. It works by starting a web server, making it accessible as a Tor onion service, and generating an unguessable web address so others can download files from you, or upload files to you. It does _not_ require setting up a separate server or using a third party file-sharing service."
-icon = "src/helloworld/resources/helloworld"
+icon = "src/onionshare/resources/onionshare"
sources = ['src/onionshare']
requires = [
+ "onionshare-cli==0.1.3",
"Click",
"eventlet",
"Flask",
@@ -29,23 +30,19 @@ requires = [
"urllib3",
]
-[tool.briefcase.app.helloworld.macOS]
+[tool.briefcase.app.onionshare.macOS]
requires = []
-[tool.briefcase.app.helloworld.linux]
+[tool.briefcase.app.onionshare.linux]
requires = []
-system_requires = []
+system_requires = ["tor", "obfs4proxy"]
-[tool.briefcase.app.helloworld.windows]
+[tool.briefcase.app.onionshare.windows]
requires = ["pywin32"]
# Mobile deployments
-[tool.briefcase.app.helloworld.iOS]
+[tool.briefcase.app.onionshare.iOS]
requires = []
-[tool.briefcase.app.helloworld.android]
+[tool.briefcase.app.onionshare.android]
requires = []
-
-# TODO: Figure out tests with briefcase
-# Test dependencies: pytest, pytest-faulthandler, pytest-qt
-# Also probably https://pypi.org/project/pytest-briefcase/ \ No newline at end of file