aboutsummaryrefslogtreecommitdiff
path: root/desktop/pyproject.toml
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2021-12-19 17:17:54 -0800
committerMicah Lee <micah@micahflee.com>2021-12-19 17:17:54 -0800
commit5aa5c9ebcc9896e37a45c6c89862a01d419f0649 (patch)
tree90cc5a7849e3f89b7293427be78d4f6f58a3a262 /desktop/pyproject.toml
parent709e4ae3c8f997e6c25bbf80c4279ad2b63acbd4 (diff)
downloadonionshare-5aa5c9ebcc9896e37a45c6c89862a01d419f0649.tar.gz
onionshare-5aa5c9ebcc9896e37a45c6c89862a01d419f0649.zip
Switch from briefcase to poetry
Diffstat (limited to 'desktop/pyproject.toml')
-rw-r--r--desktop/pyproject.toml56
1 files changed, 19 insertions, 37 deletions
diff --git a/desktop/pyproject.toml b/desktop/pyproject.toml
index 79056ada..580994a6 100644
--- a/desktop/pyproject.toml
+++ b/desktop/pyproject.toml
@@ -1,41 +1,23 @@
-[tool.briefcase]
-project_name = "OnionShare"
-bundle = "org.onionshare"
-version = "2.4"
-url = "https://onionshare.org"
-license = "GPLv3"
-author = 'Micah Lee'
-author_email = "micah@micahflee.com"
+[tool.poetry]
+name = "onionshare"
+version = "4.2.1"
+description = "OnionShare lets you securely and anonymously send and receive files. It works by starting a web server, making it accessible as a Tor onion service, and generating an unguessable web address so others can download files from you, or upload files to you. It does _not_ require setting up a separate server or using a third party file-sharing service."
+authors = ["Micah Lee <micah@micahflee.com>"]
+license = "GPLv3+"
-[tool.briefcase.app.onionshare]
-formal_name = "OnionShare"
-description = "Securely and anonymously share files, host websites, and chat with friends using the Tor network"
-icon = "src/onionshare/resources/onionshare"
-sources = ['src/onionshare']
-requires = [
- "./onionshare_cli-2.4-py3-none-any.whl",
- "pyside2==5.15.1",
- "qrcode"
-]
+[tool.poetry.dependencies]
+python = ">=3.9,<3.10"
+onionshare_cli = {path = "../cli", develop = false}
+PySide2 = "5.15.2"
+qrcode = "*"
+cx_freeze = {version = "*", platform = "win32"}
-[tool.briefcase.app.onionshare.macOS]
-requires = []
+[tool.poetry.dev-dependencies]
+black = "*"
-[tool.briefcase.app.onionshare.linux]
-requires = []
-system_requires = [
- "tor",
- "obfs4proxy",
- "gcc",
- "python3-dev",
-]
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"
-[tool.briefcase.app.onionshare.windows]
-requires = ["pywin32"]
-
-# Mobile deployments
-[tool.briefcase.app.onionshare.iOS]
-requires = []
-
-[tool.briefcase.app.onionshare.android]
-requires = []
+[tool.poetry.scripts]
+onionshare = 'onionshare:main' \ No newline at end of file