aboutsummaryrefslogtreecommitdiff
path: root/cli/setup.py
diff options
context:
space:
mode:
authorMicah Lee <micah@micahflee.com>2020-11-03 21:48:22 -0800
committerMicah Lee <micah@micahflee.com>2020-11-03 21:48:22 -0800
commitf8437c4fea88dc5643f1d9b225a6a6eab0c89606 (patch)
tree2edb21864429332749dc05ed9da122ef17d9ecbb /cli/setup.py
parent3cef5c1679019f70458557d29c4b26d00e969e96 (diff)
downloadonionshare-f8437c4fea88dc5643f1d9b225a6a6eab0c89606.tar.gz
onionshare-f8437c4fea88dc5643f1d9b225a6a6eab0c89606.zip
Make snapcraft packaging work with briefcase refactor
Diffstat (limited to 'cli/setup.py')
-rw-r--r--cli/setup.py78
1 files changed, 78 insertions, 0 deletions
diff --git a/cli/setup.py b/cli/setup.py
new file mode 100644
index 00000000..23d00066
--- /dev/null
+++ b/cli/setup.py
@@ -0,0 +1,78 @@
+#!/usr/bin/env python3
+# -*- coding: utf-8 -*-
+"""
+OnionShare | https://onionshare.org/
+
+Copyright (C) 2014-2020 Micah Lee, et al. <micah@micahflee.com>
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 3 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+"""
+
+# snap packaging uses setup.py
+# PyPi publishing, developing, and testing uses poetry
+
+import os
+import setuptools
+
+with open(
+ os.path.join(
+ os.path.dirname(os.path.dirname(os.path.abspath(__file__))), "pyproject.toml"
+ )
+) as f:
+ for line in f.readlines():
+ if line.startswith("version = "):
+ version = line.split('"')[1]
+ break
+
+setuptools.setup(
+ name="onionshare-cli",
+ version=version,
+ description="OnionShare lets you securely and anonymously send and receive files. It works by starting a web server, making it accessible as a Tor onion service, and generating an unguessable web address so others can download files from you, or upload files to you. It does _not_ require setting up a separate server or using a third party file-sharing service.",
+ author="Micah Lee",
+ author_email="micah@micahflee.com",
+ maintainer="Micah Lee",
+ maintainer_email="micah@micahflee.com",
+ url="https://onionshare.org",
+ license="GPLv3",
+ keywords="onion, share, onionshare, tor, anonymous, web server",
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "Framework :: Flask",
+ "Topic :: Communications :: File Sharing",
+ "Topic :: Security :: Cryptography",
+ "License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)",
+ "Intended Audience :: End Users/Desktop",
+ "Operating System :: OS Independent",
+ "Environment :: Web Environment",
+ ],
+ packages=[
+ "onionshare_cli",
+ "onionshare_cli.web",
+ ],
+ package_data={
+ "onionshare": [
+ "resources/*",
+ "resources/static/*",
+ "resources/static/css/*",
+ "resources/static/img/*",
+ "resources/static/js/*",
+ "resources/templates/*",
+ ]
+ },
+ entry_points={
+ "console_scripts": [
+ "onionshare-cli = onionshare_cli:main",
+ ],
+ },
+)