aboutsummaryrefslogtreecommitdiff
path: root/cli/pyproject.toml
diff options
context:
space:
mode:
authorSaptak Sengupta <saptak013@gmail.com>2023-06-06 13:01:24 +0530
committerGitHub <noreply@github.com>2023-06-06 13:01:24 +0530
commitf3fec65ef4c91f1225328da5f682c3ba8ea5f0ba (patch)
tree5e6be2c1d0313efb9ba8244b8546645a23132fdb /cli/pyproject.toml
parentefaa5105e731fc7f8dd41162f7bee0e787ca2b16 (diff)
parentd6c732e20c5dac738462eb438272bfc053d844ce (diff)
downloadonionshare-f3fec65ef4c91f1225328da5f682c3ba8ea5f0ba.tar.gz
onionshare-f3fec65ef4c91f1225328da5f682c3ba8ea5f0ba.zip
Merge pull request #1677 from onionshare/update-deps
Update deps & switch to waitress for running flask servers
Diffstat (limited to 'cli/pyproject.toml')
-rw-r--r--cli/pyproject.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/cli/pyproject.toml b/cli/pyproject.toml
index 1da61878..f6ff9c94 100644
--- a/cli/pyproject.toml
+++ b/cli/pyproject.toml
@@ -18,7 +18,8 @@ classifiers = [
[tool.poetry.dependencies]
python = ">=3.8,<3.12"
click = "*"
-flask = "2.0.3"
+flask = "2.3.2"
+flask-compress = "^1.13"
flask-socketio = "5.3.4"
psutil = "*"
pysocks = "*"
@@ -31,7 +32,8 @@ pynacl = "*"
colorama = "*"
gevent-websocket = "*"
stem = "1.8.1"
-werkzeug = "~2.0.3"
+waitress = "^2.1.2"
+werkzeug = ">=2.3.4"
[tool.poetry.dev-dependencies]
pytest = ">=7.2.0"