aboutsummaryrefslogtreecommitdiff
path: root/cli/pyproject.toml
diff options
context:
space:
mode:
authorMiguel Jacq <mig@mig5.net>2023-05-29 14:46:17 +1000
committerMiguel Jacq <mig@mig5.net>2023-05-29 14:46:17 +1000
commit83b2bf2f0c27d0da90bc50552a7741924ecdcd40 (patch)
treea595d24d8ef79520494199b8010e897cbaa923e3 /cli/pyproject.toml
parentf41d5587d0c9ddbdc619f25c01656ea4c51f6e14 (diff)
downloadonionshare-83b2bf2f0c27d0da90bc50552a7741924ecdcd40.tar.gz
onionshare-83b2bf2f0c27d0da90bc50552a7741924ecdcd40.zip
Switch to Waitress and Flask-Compress in lieu of werkzeug server
Diffstat (limited to 'cli/pyproject.toml')
-rw-r--r--cli/pyproject.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/cli/pyproject.toml b/cli/pyproject.toml
index 1f26410e..f6ff9c94 100644
--- a/cli/pyproject.toml
+++ b/cli/pyproject.toml
@@ -19,6 +19,7 @@ classifiers = [
python = ">=3.8,<3.12"
click = "*"
flask = "2.3.2"
+flask-compress = "^1.13"
flask-socketio = "5.3.4"
psutil = "*"
pysocks = "*"
@@ -31,7 +32,8 @@ pynacl = "*"
colorama = "*"
gevent-websocket = "*"
stem = "1.8.1"
-werkzeug = ">=2.3.4,<2.4.0"
+waitress = "^2.1.2"
+werkzeug = ">=2.3.4"
[tool.poetry.dev-dependencies]
pytest = ">=7.2.0"