aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Stapelberg <michael@stapelberg.de>2020-06-06 13:45:52 +0200
committerMichael Stapelberg <michael@stapelberg.de>2020-06-06 14:14:24 +0200
commitac5368770e964802243fca48dc8793d86b7e6ffd (patch)
treed63b47154c057aaeae61fd75cf8342614e390f50 /meson.build
parentff77b671019523b97c47c51c7167bd25dea8f17c (diff)
downloadi3-ac5368770e964802243fca48dc8793d86b7e6ffd.tar.gz
i3-ac5368770e964802243fca48dc8793d86b7e6ffd.zip
add i3test_pm dependency after all
I suppose the now-conditional docs building had previously pulled in i3test_pm implicitly. related to #4086
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0ca0d413..f5294936 100644
--- a/meson.build
+++ b/meson.build
@@ -611,6 +611,9 @@ complete_run = custom_target(
output: ['complete-run.pl'],
capture: true,
command: replace_dirs,
+ # build this target when running e.g. ninja or ninja test.
+ # This is required for older meson versions (< 0.46.0).
+ build_by_default: true,
)
i3test_pm = custom_target(
'i3test-pm',
@@ -618,6 +621,9 @@ i3test_pm = custom_target(
output: ['i3test.pm'],
capture: true,
command: replace_dirs,
+ # build this target when running e.g. ninja or ninja test.
+ # This is required for older meson versions (< 0.46.0).
+ build_by_default: true,
)
if get_option('docs')
@@ -694,9 +700,8 @@ if meson.version().version_compare('>=0.46.0')
perl,
args: [complete_run],
depends: [
- # i3test.pm is generated at meson configure time,
- # so no explicit dependency is required.
anyevent_i3,
+ i3test_pm,
],
)
else