aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <chrisduerr@users.noreply.github.com>2019-04-04 23:11:29 +0000
committerGitHub <noreply@github.com>2019-04-04 23:11:29 +0000
commitf0dbfc9b9c6514bc60e271bb74c2970e645d998f (patch)
tree2615f12f1335c7d80394d6c6d96dbdd01708c6ad /Cargo.toml
parent5776ec09d6d56540549fc513273ae511d3316f22 (diff)
downloadalacritty-f0dbfc9b9c6514bc60e271bb74c2970e645d998f.tar.gz
alacritty-f0dbfc9b9c6514bc60e271bb74c2970e645d998f.zip
Fix build errors on BSDv0.3.0-rc3
This updates winit and glutin to the latest git versions instead of relying on releases to fix a build failure on BSD. Unfortunately the upstream version bumps might still take a bit and there hasn't been any feedback with regards to a planned release date. This also fixes a slight issue on Windows where selections would start when focusing a window and a build failure with some Linux systems Fixes #2243. Fixes #2170. Fixes #2244.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 270d0d43..dd0b99b0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -42,7 +42,7 @@ clap = "2"
fnv = "1"
unicode-width = "0.1"
arraydeque = "0.4"
-glutin = { version = "0.20", features = ["icon_loading"] }
+glutin = { git = "https://github.com/chrisduerr/glutin", branch = "bsd-build-fix", features = ["icon_loading"] }
env_logger = "0.6.0"
base64 = "0.10.0"
static_assertions = "0.3.0"