aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorTheodore Dubois <tblodt@icloud.com>2019-04-28 06:24:58 -0700
committerChristian Duerr <chrisduerr@users.noreply.github.com>2019-04-28 13:24:58 +0000
commitdbd8538762ef8968a493e1bf996e8693479ca783 (patch)
tree32ac2a6a5e01238a272d4ba534551d2e42903c7a /Cargo.toml
parent9c6d12ea2c863ba76015bdedc00db13b7307725a (diff)
downloadalacritty-dbd8538762ef8968a493e1bf996e8693479ca783.tar.gz
alacritty-dbd8538762ef8968a493e1bf996e8693479ca783.zip
Split alacritty into a separate crates
The crate containing the entry point is called alacritty, and the crate containing everything else is called alacritty_terminal.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml105
1 files changed, 2 insertions, 103 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 112469c5..1ac20a5e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,117 +1,16 @@
-[package]
-name = "alacritty"
-version = "0.3.2"
-authors = ["Joe Wilm <joe@jwilm.com>"]
-license = "Apache-2.0"
-build = "build.rs"
-description = "GPU-accelerated terminal emulator"
-readme = "README.md"
-homepage = "https://github.com/jwilm/alacritty"
-edition = "2018"
-
[workspace]
members = [
+ "alacritty",
+ "alacritty_terminal",
"font",
"copypasta",
"winpty"
]
-[[bin]]
-doc = false
-path = "src/main.rs"
-name = "alacritty"
-
-[dependencies]
-libc = "0.2"
-notify = "4"
-bitflags = "1"
-font = { path = "./font" }
-errno = "0.2"
-parking_lot = "0.7"
-serde = "1"
-serde_derive = "1"
-serde_json = "1"
-serde_yaml = "0.8"
-vte = "0.3"
-mio = "0.6"
-mio-extras = "2"
-copypasta = { path = "./copypasta" }
-xdg = "2"
-log = "0.4"
-clap = "2"
-fnv = "1"
-unicode-width = "0.1"
-glutin = { version = "0.21.0", features = ["icon_loading"] }
-env_logger = "0.6.0"
-base64 = "0.10.0"
-static_assertions = "0.3.0"
-terminfo = "0.6.1"
-url = "1.7.1"
-time = "0.1.40"
-crossbeam-channel = "0.3.8"
-
-[target.'cfg(unix)'.dependencies]
-nix = "0.13"
-signal-hook = { version = "0.1", features = ["mio-support"] }
-
-[target.'cfg(any(target_os = "linux", target_os = "freebsd", target_os="dragonfly", target_os="openbsd"))'.dependencies]
-x11-dl = "2"
-
-[target.'cfg(windows)'.dependencies]
-winpty = { path = "./winpty" }
-mio-named-pipes = "0.1"
-miow = "0.3"
-dunce = "1.0"
-winapi = { version = "0.3.7", features = ["impl-default", "winuser", "synchapi", "roerrorapi", "winerror", "wincon", "wincontypes"]}
-dirs = "1.0"
-widestring = "0.4"
-mio-anonymous-pipes = "0.1"
-image = "0.21.0"
-
-[target.'cfg(target_os = "macos")'.dependencies]
-objc = "0.2.2"
-dirs = "1.0.2"
-
-[features]
-default = []
-# Enabling this feature makes shaders automatically reload when changed
-live-shader-reload = []
-nightly = []
-bench = []
-
-[build-dependencies]
-gl_generator = "0.11.0"
-
-[target.'cfg(windows)'.build-dependencies]
-embed-resource = "1.1.4"
-tempfile = "3.0.4"
-reqwest = "0.9"
-zip = "0.5"
-
[profile.release]
lto = true
debug = 1
incremental = false
-[package.metadata.deb]
-maintainer = "Joe Wilm <joe@jwilm.com>"
-license-file = ["LICENSE-APACHE", "3"]
-extended-description = """\
-Alacritty is the fastest terminal emulator in existence. Using the GPU for \
-rendering enables optimizations that simply aren't possible without it. """
-depends = "$auto"
-section = "rust"
-priority = "optional"
-assets = [
- ["target/release/alacritty", "usr/bin/", "755"],
- ["extra/linux/alacritty.desktop", "usr/share/applications/", "644"],
- ["extra/logo/alacritty-term.svg", "usr/share/pixmaps/Alacritty.svg", "644"],
- ["extra/completions/alacritty.bash", "usr/share/bash-completion/completions/alacritty", "644"],
- ["extra/completions/alacritty.fish", "usr/share/fish/completions/alacritty.fish", "644"],
- ["extra/completions/_alacritty", "usr/share/zsh/vendor-completions/_alacritty", "644"],
- ["extra/alacritty.info", "usr/share/terminfo/a/alacritty", "644"],
-]
-maintainer-scripts = "extra/linux/debian"
-
[patch.crates-io]
servo-freetype-sys = { path = "servo-freetype-proxy" }