aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <chrisduerr@users.noreply.github.com>2019-04-02 23:29:36 +0000
committerGitHub <noreply@github.com>2019-04-02 23:29:36 +0000
commit86ccd0566edf97849079889a80e67669332c37cb (patch)
tree76b74f5321c44413c2530885ca067ffbb2456805 /Cargo.toml
parent48d781d1238835db9f2d30742ccf50dd53be7bed (diff)
downloadalacritty-86ccd0566edf97849079889a80e67669332c37cb.tar.gz
alacritty-86ccd0566edf97849079889a80e67669332c37cb.zip
Fix BSD build failure
This updates all dependencies removing any reference to nix 0.12 which prevents successful builds on OpenBSD. Fixes #2244.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 860b6740..b4e41196 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -52,7 +52,7 @@ time = "0.1.40"
crossbeam-channel = "0.3.8"
[target.'cfg(unix)'.dependencies]
-nix = "0.12"
+nix = "0.13"
signal-hook = { version = "0.1", features = ["mio-support"] }
[target.'cfg(any(target_os = "linux", target_os = "freebsd", target_os="dragonfly", target_os="openbsd"))'.dependencies]