aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMicha Gorelick <mynameisfiber@gmail.com>2018-11-03 11:08:30 -0400
committerChristian Duerr <chrisduerr@users.noreply.github.com>2018-11-03 15:08:30 +0000
commit77816797e80d42d5fb626379a15dc94c09cd3694 (patch)
tree445f7b37a73ab108c0503ca59621e3d54de42229 /Cargo.toml
parentfd8af0df3395a13f7fe670e293ee9584669aa7bd (diff)
downloadalacritty-77816797e80d42d5fb626379a15dc94c09cd3694.tar.gz
alacritty-77816797e80d42d5fb626379a15dc94c09cd3694.zip
Publish Github releases from Travis
This release introduces some config to automatically build deploy a binaries on the github release page using travis. The build only happens when a commit is tagged and it uses the stable version of rust. The main travis sections (install/script/before_deploy) have been moved out of the .travis.yml to make it easier to read, maintain and extend the different steps of the CI process. Since checking for the Rust version in CI is enough to know if clippy should be used or not, the environment variable `CLIPPY` has also been removed, which further allowed simplifying the CI process. Besides the executables, some auxillary files are now also published as part of a release when they have changed since the last tagged Alacritty release. This should make it clear for returning users when a new version of a specific auxillary file is required. Instead of using the 14.04 image which travis provides by default, an 18.04 docker image is used to build the output binaries for Linux. This affects both the .deb and the .tar.gz binary. The advantage of this is that while binaries compiled on 14.04, do not work on 18.04, it does work the other way around. The generated .tar.gz binary has been tested on 18.04, Debian, Fedora and Archlinux and all systems were able to run it without any warnings or errors.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e985de85..eef025ba 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -92,7 +92,7 @@ Alacritty is the fastest terminal emulator in existence. Using the GPU for \
rendering enables optimizations that simply aren't possible in other emulators. \
Alacritty currently supports FreeBSD, Linux, macOS, and OpenBSD. Windows \
support is planned before the 1.0 release. """
-depends = "$auto, cmake, libfreetype6-dev, libfontconfig1-dev, xclip"
+depends = "$auto"
section = "rust"
priority = "optional"
assets = [