aboutsummaryrefslogtreecommitdiff
path: root/src/rust/tor_log/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/rust/tor_log/Cargo.toml')
-rw-r--r--src/rust/tor_log/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/rust/tor_log/Cargo.toml b/src/rust/tor_log/Cargo.toml
index 9d06299c05..1aa9be0612 100644
--- a/src/rust/tor_log/Cargo.toml
+++ b/src/rust/tor_log/Cargo.toml
@@ -9,6 +9,11 @@ path = "lib.rs"
crate_type = ["rlib", "staticlib"]
[features]
+# We have to define a feature here because doctests don't get cfg(test),
+# and we need to disable some C dependencies when running the doctests
+# because of the various linker issues. See
+# https://github.com/rust-lang/rust/issues/45599
+test_linking_hack = []
[dependencies]
libc = "0.2.39"