aboutsummaryrefslogtreecommitdiff
path: root/src/rust/protover/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/rust/protover/Cargo.toml')
-rw-r--r--src/rust/protover/Cargo.toml11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/rust/protover/Cargo.toml b/src/rust/protover/Cargo.toml
index 86301b8787..2f7783e76c 100644
--- a/src/rust/protover/Cargo.toml
+++ b/src/rust/protover/Cargo.toml
@@ -3,6 +3,13 @@ authors = ["The Tor Project"]
version = "0.0.1"
name = "protover"
+[features]
+# We have to define a feature here because doctests don't get cfg(test),
+# and we need to disable some C dependencies when running the doctests
+# because of the various linker issues. See
+# https://github.com/rust-lang/rust/issues/45599
+test_linking_hack = []
+
[dependencies]
libc = "=0.2.39"
@@ -18,8 +25,10 @@ path = "../tor_util"
[dependencies.tor_allocate]
path = "../tor_allocate"
+[dependencies.tor_log]
+path = "../tor_log"
+
[lib]
name = "protover"
path = "lib.rs"
crate_type = ["rlib", "staticlib"]
-