aboutsummaryrefslogtreecommitdiff
path: root/src/rust/external/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/rust/external/Cargo.toml')
-rw-r--r--src/rust/external/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/rust/external/Cargo.toml b/src/rust/external/Cargo.toml
new file mode 100644
index 0000000000..5f443645bb
--- /dev/null
+++ b/src/rust/external/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+authors = ["The Tor Project"]
+version = "0.0.1"
+name = "external"
+
+[dependencies]
+libc = "=0.2.39"
+smartlist = { path = "../smartlist" }
+tor_allocate = { path = "../tor_allocate" }
+
+[lib]
+name = "external"
+path = "lib.rs"
+
+[features]
+# We have to define a feature here because doctests don't get cfg(test),
+# and we need to disable some C dependencies when running the doctests
+# because of the various linker issues. See
+# https://github.com/rust-lang/rust/issues/45599
+test_linking_hack = []