aboutsummaryrefslogtreecommitdiff
path: root/src/rust/crypto/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/rust/crypto/Cargo.toml')
-rw-r--r--src/rust/crypto/Cargo.toml15
1 files changed, 11 insertions, 4 deletions
diff --git a/src/rust/crypto/Cargo.toml b/src/rust/crypto/Cargo.toml
index e6a8bffa27..8b489dfb47 100644
--- a/src/rust/crypto/Cargo.toml
+++ b/src/rust/crypto/Cargo.toml
@@ -13,9 +13,16 @@ crate_type = ["rlib", "staticlib"]
[dependencies]
libc = "=0.2.39"
digest = "=0.7.2"
+rand_core = "=0.1.0"
-[dependencies.external]
-path = "../external"
+external = { path = "../external" }
+smartlist = { path = "../smartlist" }
+tor_allocate = { path = "../tor_allocate" }
+tor_log = { path = "../tor_log" }
+
+[dev-dependencies]
+rand = { version = "=0.5.0-pre.1", default-features = false }
+
+[features]
+testing = ["tor_log/testing"]
-[dependencies.smartlist]
-path = "../smartlist"