aboutsummaryrefslogtreecommitdiff
path: root/src/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/rust/Cargo.toml')
-rw-r--r--src/rust/Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml
index c3e44d2a79..de8693ea33 100644
--- a/src/rust/Cargo.toml
+++ b/src/rust/Cargo.toml
@@ -10,7 +10,17 @@ members = [
"tor_util",
]
+# Can remove panic="abort" when this issue is fixed:
+# https://github.com/rust-lang/rust/issues/52652
+[profile.dev]
+panic = "abort"
+
[profile.release]
debug = true
panic = "abort"
+[profile.test]
+panic = "abort"
+
+[profile.bench]
+panic = "abort"