aboutsummaryrefslogtreecommitdiff
path: root/src/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/rust/Cargo.toml')
-rw-r--r--src/rust/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml
new file mode 100644
index 0000000000..de8693ea33
--- /dev/null
+++ b/src/rust/Cargo.toml
@@ -0,0 +1,26 @@
+[workspace]
+members = [
+ "crypto",
+ "external",
+ "protover",
+ "smartlist",
+ "tor_allocate",
+ "tor_log",
+ "tor_rust",
+ "tor_util",
+]
+
+# Can remove panic="abort" when this issue is fixed:
+# https://github.com/rust-lang/rust/issues/52652
+[profile.dev]
+panic = "abort"
+
+[profile.release]
+debug = true
+panic = "abort"
+
+[profile.test]
+panic = "abort"
+
+[profile.bench]
+panic = "abort"