summaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index 5e8ba27897..779ae6acaa 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -35,8 +35,8 @@ micro-revision.i: FORCE
svn info ../.. | \
sed -n 's/^Revision: \([0-9][0-9]*\).*/"\1"/p' > micro-revision.i \
|| true; \
- fi; \
- if test ! -f micro-revision.i -a x`which svk` != x; then\
+ else \
+ if test x`which svk` != x; then \
location=../..; \
rev=x; \
while test x$$rev = xx; do \
@@ -59,6 +59,7 @@ micro-revision.i: FORCE
echo \"$$rev\" > micro-revision.i; \
fi; \
fi; \
+ fi; \
if test ! -f micro-revision.i; then \
echo '""' > micro-revision.i; \
fi