summaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index d0e78a5525..f296776902 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -1,4 +1,8 @@
+TESTS = test_config
+
+noinst_PROGRAMS = test_config
+
bin_PROGRAMS = or
or_LDADD = -L../common -lor
@@ -7,6 +11,10 @@ or_SOURCES = args.c buffers.c cell.c circuit.c command.c connection.c \
connection_exit.c connection_ap.c connection_op.c connection_or.c config.c \
main.c onion.c routers.c
+test_config_SOURCES = test_config.c
+
+test_config_LDADD = config.o -L../common -lor
+
noinst_HEADERS = or.h