aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index 5fda7e5cbc..c0646df31b 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -39,11 +39,11 @@ noinst_HEADERS = or.h eventdns.h eventdns_tor.h micro-revision.i
tor_main.o: micro-revision.i
micro-revision.i: FORCE
- @if test -d ../../.svn && test x`which svn` != x ; then \
+ @if test -d ../../.svn && test -x "`which svn 2>&1`" ; then \
svn info ../.. | \
sed -n 's/^Revision: \([0-9][0-9]*\).*/"\1"/p' > micro-revision.tmp \
|| true; \
- elif test x`which svk` != x && test -d ~/.svk/local; then \
+ elif test -x "`which svk 2>&1`" && test -d ~/.svk/local; then \
location=../..; \
rev=x; \
while test x$$rev = xx; do \