aboutsummaryrefslogtreecommitdiff
path: root/src/or/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/or/Makefile.am')
-rw-r--r--src/or/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/or/Makefile.am b/src/or/Makefile.am
index ef079a45c1..93f9edb198 100644
--- a/src/or/Makefile.am
+++ b/src/or/Makefile.am
@@ -13,6 +13,9 @@ tor_SOURCES = buffers.c circuitbuild.c circuitlist.c \
eventdns.c \
tor_main.c
+tor_LIBS = -lz -levent -lssl -lcrypto
+tor_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ @TOR_LDFLAGS_libevent@ \
+ -lz -levent -lssl -lcrypto
tor_LDADD = ../common/libor.a ../common/libor-crypto.a
test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
@@ -24,6 +27,8 @@ test_SOURCES = buffers.c circuitbuild.c circuitlist.c \
eventdns.c \
test.c
+test_LDFLAGS = @TOR_LDFLAGS_zlib@ @TOR_LDFLAGS_openssl@ \
+ @TOR_LDFLAGS_libevent@ -lz -levent -lssl -lcrypto
test_LDADD = ../common/libor.a ../common/libor-crypto.a
noinst_HEADERS = or.h eventdns.h eventdns_tor.h micro-revision.i