summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index d48678f505..47964e0aa5 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -6,4 +6,8 @@ noinst_LIBRARIES = libor.a libor-crypto.a
libor_a_SOURCES = log.c util.c compat.c container.c mempool.c
libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
+if USE_OPENBSD_MALLOC
+libor_a_SOURCES += OpenBSD_Malloc_Linux.c
+endif
+
noinst_HEADERS = log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h