aboutsummaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index de9b566e4e..28702bb10a 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -3,11 +3,14 @@ noinst_LIBRARIES = libor.a libor-crypto.a
#CFLAGS = -Wall -Wpointer-arith -O2
-libor_a_SOURCES = log.c util.c compat.c container.c mempool.c
-libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
-
if USE_OPENBSD_MALLOC
-libor_a_SOURCES += OpenBSD_malloc_Linux.c
+libor_extra_source=OpenBSD_malloc_Linux.c
+else
+libor_extra_source=
endif
+libor_a_SOURCES = log.c util.c compat.c container.c mempool.c \
+ $(libor_extra_source)
+libor_crypto_a_SOURCES = crypto.c aes.c tortls.c torgzip.c
+
noinst_HEADERS = log.h crypto.h test.h util.h compat.h aes.h torint.h tortls.h strlcpy.c strlcat.c torgzip.h container.h ht.h mempool.h