aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 2eae7a1871..4810d2538d 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -5,12 +5,12 @@ html_in = $(asciidoc_files:=.html.in)
man_in = $(asciidoc_files:=.1.in)
EXTRA_DIST = HACKING \
- tor-resolve.1 tor-gencert.1 \
+ tor-resolve.1 \
$(html_in) $(man_in) $(asciidoc_files:=.1.txt) \
tor-osx-dmg-creation.txt tor-rpm-creation.txt \
tor-win32-mingw-creation.txt torify.1
-nodist_man_MANS = tor.1 tor-resolve.1 tor-gencert.1 torify.1 $(asciidoc_files:=.1)
+nodist_man_MANS = tor.1 tor-resolve.1 torify.1 $(asciidoc_files:=.1)
doc_DATA = $(asciidoc_files:=.html)
@@ -25,12 +25,19 @@ DIST_SUBDIRS = design-paper spec
$(html_in) :
$(top_srcdir)/doc/asciidoc-helper.sh html @ASCIIDOC@ @SED@ $@
+tor-gencert.html.in : tor-gencert.1.txt
+
# Generate the manpage from asciidoc, but don't do
# machine-specific replacements yet
$(man_in) :
$(top_srcdir)/doc/asciidoc-helper.sh man @A2X@ @SED@ $@
+tor-gencert.1.in : tor-gencert.1.txt
+
# use ../config.status to swap all machine-specific magic strings
# in the asciidoc with their replacements.
$(asciidoc_product) :
../config.status --file=$@;
+
+tor-gencert.1 : tor-gencert.1.in
+tor-gencert.html : tor-gencert.html.in