summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rwxr-xr-xdebian/rules4
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 748e645275..8bb4c25bac 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,8 +2,11 @@ tor (0.2.0.21-rc-+svn) XXperimental; urgency=low
* Work around fig2dev failing to build the images on all archs
(re #457568).
+ * Build with --enable-openbsd-malloc, unless no-enable-openbsd-malloc is
+ found in DEB_BUILD_OPTIONS. Hopefully this deals with some of the
+ horrible memory fragmentation that glibc's malloc causes.
- -- Peter Palfrader <weasel@debian.org> Wed, 5 Mar 2008 09:47:53 +0100
+ -- Peter Palfrader <weasel@debian.org> Tue, 11 Mar 2008 14:51:47 +0100
tor (0.2.0.21-rc-1) experimental; urgency=low
diff --git a/debian/rules b/debian/rules
index dc836cafc2..24d727175b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -53,6 +53,10 @@ CONF_OPTIONS =
ifneq (,$(findstring with-dmalloc,$(DEB_BUILD_OPTIONS)))
CONF_OPTIONS += --with-dmalloc
endif
+# inhibit building with --enable-openbsd-malloc
+ifeq (,$(findstring no-enable-openbsd-malloc,$(DEB_BUILD_OPTIONS)))
+ CONF_OPTIONS += --enable-openbsd-malloc
+endif
configure: patch-stamp
config.status: configure