summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 24d727175b..3d38b4f229 100755
--- a/debian/rules
+++ b/debian/rules
@@ -88,7 +88,7 @@ build-stamp: config.status
src/or/test || true; \
else \
echo "src/or/test"; \
- src/or/test; \
+ src/or/test || true; \
fi; \
else \
echo -e "\n\nSkipping unittests\n\n"; \
@@ -159,6 +159,9 @@ install: build
install -d -m 755 $(CURDIR)/debian/tor-dbg/usr/share/doc
ln -s tor $(CURDIR)/debian/tor-dbg/usr/share/doc/tor-dbg
+ mv $(CURDIR)/debian/tor/usr/share/tor/geoip $(CURDIR)/debian/tor-geoipdb/usr/share/tor
+ rmdir $(CURDIR)/debian/tor/usr/share/tor || true
+
# Build architecture-independent files here.
binary-indep: build install