aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 3 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 9ac9da1706..dc836cafc2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -100,17 +100,15 @@ build-stamp: config.status
#
# the hexdumps were built using something like
# perl -e 'while (<>) { print unpack ("H*", $_); }' interaction.pdf | fold > hexdump-interaction.pdf
- if [ "$(DEB_BUILD_GNU_TYPE)" = "s390-linux-gnu" ] || \
- [ "$(DEB_BUILD_GNU_TYPE)" = "sparc-linux-gnu" ] || \
- [ "$(DEB_BUILD_GNU_TYPE)" = "mipsel-linux" ]; then \
- cd doc/design-paper; \
+ #
+ # And it fails on a bunch of other archs too.
+ cd doc/design-paper; \
fig2dev -L pdf cell-struct.fig cell-struct.pdf || \
( echo "** Using shipped pdf file because fig2dev failed"; \
perl -e 'while (<>) { chomp; print pack ("H*", $$_); }' ../../debian/hexdump-cell-struct.pdf > cell-struct.pdf ); \
fig2dev -L pdf interaction.fig interaction.pdf || \
( echo "** Using shipped pdf file because fig2dev failed"; \
perl -e 'while (<>) { chomp; print pack ("H*", $$_); }' ../../debian/hexdump-interaction.pdf > interaction.pdf ); \
- fi
# XXX ends
make -C doc/design-paper tor-design.ps tor-design.pdf