summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 1f045f1349..c167b8d40d 100644
--- a/configure.in
+++ b/configure.in
@@ -295,20 +295,22 @@ dnl Check for functions before libevent, since libevent-1.2 apparently
dnl exports strlcpy without defining it in a header.
AC_CHECK_FUNCS(
- accept4 \
- clock_gettime \
+ accept4 \
+ clock_gettime \
flock \
ftime \
getaddrinfo \
+ getifaddrs \
getrlimit \
gettimeofday \
gmtime_r \
inet_aton \
+ ioctl \
localtime_r \
- lround \
+ lround \
memmem \
prctl \
- rint \
+ rint \
socketpair \
strlcat \
strlcpy \
@@ -624,6 +626,7 @@ dnl These headers are not essential
AC_CHECK_HEADERS(
arpa/inet.h \
grp.h \
+ ifaddrs.h \
inttypes.h \
limits.h \
linux/types.h \
@@ -632,6 +635,7 @@ AC_CHECK_HEADERS(
malloc/malloc.h \
malloc_np.h \
netdb.h \
+ net/if.h \
netinet/in.h \
netinet/in6.h \
pwd.h \