summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f34e3213ea..f3843f8e6a 100644
--- a/configure.in
+++ b/configure.in
@@ -368,6 +368,14 @@ case $host in
ia64-*-* | arm-*-* | sparc-*-* )
tor_cv_unaligned_ok=no
;;
+ # On the following architectures unaligned access works, but is not done in
+ # hardware. This means that when you try to do unaligned access the kernel
+ # gets to sort out an exception and then work around to somehow make your
+ # reqest work, which is quite expensive. Therefore it's probably better to
+ # not even do it.
+ alpha-*-* | mips-*-* | mipsel-*-* )
+ tor_cv_unaligned_ok=no
+ ;;
*)
AC_CACHE_CHECK([whether unaligned int access is allowed], tor_cv_unaligned_ok,
[AC_RUN_IFELSE([AC_LANG_SOURCE(