summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 22 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index b05e935343..f4a8e1ee19 100644
--- a/configure.in
+++ b/configure.in
@@ -279,7 +279,7 @@ fi
AC_C_BIGENDIAN
-AC_SEARCH_LIBS(socket, [socket])
+AC_SEARCH_LIBS(socket, [socket network])
AC_SEARCH_LIBS(gethostbyname, [nsl])
AC_SEARCH_LIBS(dlopen, [dl])
AC_SEARCH_LIBS(inet_aton, [resolv])
@@ -295,20 +295,22 @@ dnl Check for functions before libevent, since libevent-1.2 apparently
dnl exports strlcpy without defining it in a header.
AC_CHECK_FUNCS(
- accept4 \
- clock_gettime \
+ accept4 \
+ clock_gettime \
flock \
ftime \
getaddrinfo \
+ getifaddrs \
getrlimit \
gettimeofday \
gmtime_r \
inet_aton \
+ ioctl \
localtime_r \
- lround \
+ lround \
memmem \
prctl \
- rint \
+ rint \
socketpair \
strlcat \
strlcpy \
@@ -483,6 +485,20 @@ fi
AC_SUBST(TOR_LIBEVENT_LIBS)
dnl ------------------------------------------------------
+dnl Where do you live, libm?
+
+dnl On some platforms (Haiku/BeOS) the math library is
+dnl part of libroot. In which case don't link against lm
+TOR_LIB_MATH=""
+save_LIBS="$LIBS"
+AC_SEARCH_LIBS(pow, [m], , AC_MSG_ERROR([Could not find pow in libm or libc.]))
+if test "$ac_cv_search_pow" != "none required"; then
+ TOR_LIB_MATH="$ac_cv_search_pow"
+fi
+LIBS="$save_LIBS"
+AC_SUBST(TOR_LIB_MATH)
+
+dnl ------------------------------------------------------
dnl Where do you live, openssl? And how do we call you?
tor_openssl_pkg_redhat="openssl"
@@ -610,6 +626,7 @@ dnl These headers are not essential
AC_CHECK_HEADERS(
arpa/inet.h \
grp.h \
+ ifaddrs.h \
inttypes.h \
limits.h \
linux/types.h \