summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7167ca9366..051c924a9d 100644
--- a/configure.in
+++ b/configure.in
@@ -566,9 +566,11 @@ if test x$enable_gcc_hardening != xno; then
TOR_CHECK_CFLAGS(-fstack-protector-all)
TOR_CHECK_CFLAGS(-Wstack-protector)
TOR_CHECK_CFLAGS(-fwrapv)
- TOR_CHECK_CFLAGS(-fPIE)
TOR_CHECK_CFLAGS(--param ssp-buffer-size=1)
- TOR_CHECK_LDFLAGS(-pie, "$all_ldflags_for_check", "$all_libs_for_check")
+ if test "$bwin32" = "false"; then
+ TOR_CHECK_CFLAGS(-fPIE)
+ TOR_CHECK_LDFLAGS(-pie, "$all_ldflags_for_check", "$all_libs_for_check")
+ fi
fi
if test x$enable_linker_hardening != xno; then