summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e4bb12d74c..ddb682379d 100644
--- a/configure.in
+++ b/configure.in
@@ -1160,12 +1160,13 @@ else
fi
# OS X Lion started deprecating the system openssl. Let's just disable
-# all deprecation warnings on OS X.
+# all deprecation warnings on OS X. Also, to potentially make the binary
+# a little smaller, let's enable dead_strip.
case "$host_os" in
darwin*)
CFLAGS="$CFLAGS -Wno-deprecated-declarations"
- ;;
+ LDFLAGS="$LDFLAGS -dead_strip" ;;
esac
# Add some more warnings which we use in development but not in the