summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3645d77d14..8e3765c81c 100644
--- a/configure.in
+++ b/configure.in
@@ -25,6 +25,15 @@ AC_ARG_ENABLE(debug,
CFLAGS="$CFLAGS -g"
fi])
+#XXXX ideally, we should make this into a no-op, and detect whether we're
+#compiling for the iphone by using $target.
+AC_ARG_ENABLE(iphone,
+ AS_HELP_STRING(--enable-iphone, compile with iPhone support),
+ [if test x$enableval = xyes ; then
+ tor_cv_iphone=true
+ CFLAGS="$CFLAGS -D__DARWIN_UINX03 -DIPHONE"
+ fi])
+
AC_ARG_ENABLE(cell-pool,
AS_HELP_STRING(--disable-cell-pool, disable pool allocator for cells))