summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 276c7b2fe4..0e3eb1f6da 100644
--- a/configure.in
+++ b/configure.in
@@ -14,11 +14,27 @@ if test -f /etc/redhat-release; then
fi
AC_ARG_ENABLE(debug,
-[ --enable-debug compiles with debugging info],
+ AC_HELP_STRING(--enable-debug, compile with debugging info),
[if test x$enableval = xyes; then
CFLAGS="$CFLAGS -g"
fi])
+AC_ARG_ENABLE(threads,
+ AC_HELP_STRING(--disable-threads, disable multi-threading support))
+
+if test x$enable_threads = x; then
+ case $ac_sys_system in
+ NetBSD*)
+ enable_threads="no";;
+ *)
+ enable_threads="yes";;
+ esac
+fi
+
+if test $enable_threads = "yes"; then
+ AC_DEFINE(ENABLE_THREADS, 1, [Defined if we will try to use multithreading])
+fi
+
AC_PROG_CC
AC_PROG_MAKE_SET
AC_PROG_RANLIB