aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 25edbaf1d9..6d2312d159 100644
--- a/configure.ac
+++ b/configure.ac
@@ -376,11 +376,15 @@ AM_CONDITIONAL(THREADS_PTHREADS, test "$bwin32" = "false")
AC_CHECK_FUNCS(
_NSGetEnviron \
+ RtlSecureZeroMemory \
+ SecureZeroMemory \
accept4 \
backtrace \
backtrace_symbols_fd \
clock_gettime \
eventfd \
+ explicit_bzero \
+ timingsafe_memcmp \
flock \
ftime \
getaddrinfo \
@@ -390,6 +394,7 @@ AC_CHECK_FUNCS(
getrlimit \
gettimeofday \
gmtime_r \
+ htonll \
inet_aton \
ioctl \
issetugid \
@@ -397,6 +402,7 @@ AC_CHECK_FUNCS(
localtime_r \
lround \
memmem \
+ memset_s \
pipe \
pipe2 \
prctl \
@@ -1155,7 +1161,6 @@ AC_CHECK_MEMBERS([struct in6_addr.s6_addr32, struct in6_addr.s6_addr16, struct s
#include <winsock2.h>
#include <ws2tcpip.h>
#endif
-#endif
])
AC_CHECK_TYPES([rlim_t], , ,