summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 27 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 6d50dc9508..9649951503 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,11 +4,13 @@ dnl Copyright (c) 2007-2019, The Tor Project, Inc.
dnl See LICENSE for licensing information
AC_PREREQ([2.63])
-AC_INIT([tor],[0.4.5.3-rc-dev])
+AC_INIT([tor],[0.4.6.1-alpha-dev])
AC_CONFIG_SRCDIR([src/app/main/tor_main.c])
AC_CONFIG_MACRO_DIR([m4])
configure_flags="$*"
+AC_DEFINE_UNQUOTED([CONFIG_FLAGS], ["$configure_flags"], [Flags passed to configure])
+
# DO NOT EDIT THIS DEFINITION BY HAND UNLESS YOU KNOW WHAT YOU'RE DOING.
#
@@ -16,7 +18,7 @@ configure_flags="$*"
# version number changes. Tor uses it to make sure that it
# only shuts down for missing "required protocols" when those protocols
# are listed as required by a consensus after this date.
-AC_DEFINE(APPROX_RELEASE_DATE, ["2021-01-12"], # for 0.4.5.3-rc-dev
+AC_DEFINE(APPROX_RELEASE_DATE, ["2021-03-18"], # for 0.4.6.1-alpha-dev
[Approximate date when this software was released. (Updated when the version changes.)])
# "foreign" means we don't follow GNU package layout standards
@@ -357,6 +359,12 @@ dnl ---
dnl All our modules.
m4_define(MODULES, relay dirauth dircache)
+# Some modules are only disabled through another option. For those, we don't
+# want to print the help in the summary at the end of the configure. Any entry
+# in the following set will not print the "--disable-module-NAME" command in
+# the summary.
+m4_set_add_all([MODULES_WITH_NO_OPTIONS], [dircache])
+
dnl Relay module.
AC_ARG_ENABLE([module-relay],
AS_HELP_STRING([--disable-module-relay],
@@ -422,6 +430,17 @@ AC_PROG_MAKE_SET
AC_PROG_RANLIB
AC_PROG_SED
+AX_COMPILER_VERSION
+AX_COMPILER_VENDOR
+
+AC_DEFINE_UNQUOTED([COMPILER_VERSION],["$ax_cv_c_compiler_version"], [Compiler version])
+AC_DEFINE_UNQUOTED([COMPILER_VENDOR],["$ax_cv_c_compiler_vendor"], [Compiler vendor])
+
+AS_CASE($ax_cv_c_compiler_vendor,
+ [gnu], AC_DEFINE([COMPILER],["GCC"],[Compiler name]),
+ AC_DEFINE([COMPILER],[],[Compiler name])
+)
+
AC_ARG_VAR([PERL], [path to Perl binary])
AC_CHECK_PROGS([PERL], [perl])
AM_CONDITIONAL(USE_PERL, [test "x$ac_cv_prog_PERL" != "x"])
@@ -1138,7 +1157,7 @@ AC_RUN_IFELSE([AC_LANG_SOURCE([AC_LANG_PROGRAM([[
]])])], [openssl_ver_mismatch=no], [
# This is a kludge to figure out whether compilation failed, or whether
# running the program failed.
- if test "$ac_retval" == "1"; then
+ if test "$ac_retval" = "1"; then
openssl_ver_mismatch=inconclusive
else
openssl_ver_mismatch=yes
@@ -2137,7 +2156,6 @@ AS_CASE([$malloc],
[system], [
# handle this later, including the jemalloc fallback
- AC_CHECK_FUNCS(mallinfo)
],
[AC_MSG_ERROR([--with-malloc=`$with_malloc' not supported, see --help])
@@ -2797,10 +2815,10 @@ PPRINT_PROP_BOOL([libscrypt (--disable-libscrypt)], $value)
test "x$enable_systemd" = "xyes" && value=1 || value=0
PPRINT_PROP_BOOL([Systemd support (--enable-systemd)], $value)
-test "x$enable_lzma" = "xyes" && value=1 || value=0
+test "x$have_lzma" = "xyes" && value=1 || value=0
PPRINT_PROP_BOOL([liblzma (--enable-lzma)], $value)
-test "x$enable_zstd" = "xyes" && value=1 || value=0
+test "x$have_zstd" = "xyes" && value=1 || value=0
PPRINT_PROP_BOOL([libzstd (--enable-zstd)], $value)
AS_ECHO
@@ -2821,7 +2839,9 @@ PPRINT_SUBTITLE([Modules])
m4_foreach_w([mname], MODULES,
[
AM_COND_IF(m4_join([], [BUILD_MODULE_], m4_toupper([]mname[])), value=1, value=0)
- PPRINT_PROP_BOOL([mname (--disable-module-mname)], $value)
+ m4_set_contains([MODULES_WITH_NO_OPTIONS], mname,
+ PPRINT_PROP_BOOL([mname], $value),
+ PPRINT_PROP_BOOL([mname (--disable-module-mname)], $value))
]
)