summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b89ae8d7c3..c254725c60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,6 +126,13 @@ else
[libsystemd-daemon],
have_systemd=yes,
have_systemd=no)
+ if test x$have_systemd=xno; then
+ AC_MSG_NOTICE([Okay, checking for systemd a different way...])
+ PKG_CHECK_MODULES(SYSTEMD,
+ [libsystemd],
+ have_systemd=yes,
+ have_systemd=no)
+ fi
fi
if test x$have_systemd = xyes; then