summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a90c15c465..ed57757a41 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1800,11 +1800,6 @@ if test "x$enable_gcc_warnings_advisory" != "xno"; then
-Wsync-nand
-Wtautological-constant-out-of-range-compare
-Wtentative-definition-incomplete-type
- -Wthread-safety
- -Wthread-safety-analysis
- -Wthread-safety-attributes
- -Wthread-safety-beta
- -Wthread-safety-precise
-Wtrampolines
-Wtype-safety
-Wtypedef-redefinition
@@ -1838,6 +1833,14 @@ if test "x$enable_gcc_warnings_advisory" != "xno"; then
-Wzero-length-array
], [ TOR_CHECK_CFLAGS([warning_flag]) ])
+dnl These seem to require annotations that we don't currently use,
+dnl and they give false positives in our pthreads wrappers. (Clang 4)
+dnl -Wthread-safety
+dnl -Wthread-safety-analysis
+dnl -Wthread-safety-attributes
+dnl -Wthread-safety-beta
+dnl -Wthread-safety-precise
+
CFLAGS="$CFLAGS -W -Wfloat-equal -Wundef -Wpointer-arith"
CFLAGS="$CFLAGS -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings"
CFLAGS="$CFLAGS -Wredundant-decls -Wchar-subscripts -Wcomment -Wformat=2"