aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6acc587610..214b7e6c2b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -396,7 +396,6 @@ dnl Check for functions before libevent, since libevent-1.2 apparently
dnl exports strlcpy without defining it in a header.
AC_CHECK_FUNCS(
- SecureZeroMemory \
_NSGetEnviron \
accept4 \
backtrace \
@@ -436,7 +435,6 @@ AC_CHECK_FUNCS(
uname \
usleep \
vasprintf \
- _getwch \
_vscprintf
)
@@ -445,6 +443,14 @@ if test "$bwin32" != true; then
AC_CHECK_FUNCS(pthread_create)
fi
+if test "$bwin32" = true; then
+ AC_CHECK_DECLS([SecureZeroMemory, _getwch], , , [
+#include <windows.h>
+#include <conio.h>
+#include <wchar.h>
+ ])
+fi
+
AM_CONDITIONAL(BUILD_READPASSPHRASE_C, test x$ac_cv_func_readpassphrase = xno && test $bwin32 = false)
dnl ------------------------------------------------------