aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 4 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index dd5bf904b2..491b4c8f9f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -168,6 +168,8 @@ EXTRA_DIST+= \
ReleaseNotes \
scripts/maint/checkIncludes.py \
scripts/maint/checkSpace.pl \
+ scripts/maint/checkShellScripts.sh \
+ scripts/maint/practracker/README \
scripts/maint/practracker/exceptions.txt \
scripts/maint/practracker/includes.py \
scripts/maint/practracker/metrics.py \
@@ -240,22 +242,7 @@ test: all
$(top_builddir)/src/test/test
shellcheck:
- # Only use shellcheck if it is present
- if command -v shellcheck; then \
- find "$(top_srcdir)" -name "*.sh" -not -path "$(top_srcdir)/src/ext/*" -not -path "$(top_srcdir)/src/rust/registry/*" -exec shellcheck {} +; \
- if [ -d "$(top_srcdir)/scripts/test" ]; then \
- shellcheck $(top_srcdir)/scripts/test/cov-diff $(top_srcdir)/scripts/test/coverage; \
- fi; \
- if [ -e "$(top_srcdir)/contrib/dirauth-tools/nagios-check-tor-authority-cert" ]; then \
- shellcheck "$(top_srcdir)/contrib/dirauth-tools/nagios-check-tor-authority-cert"; \
- fi; \
- if [ -e "$(top_srcdir)/contrib/client-tools/torify" ]; then \
- shellcheck "$(top_srcdir)/contrib/client-tools/torify"; \
- fi; \
- if [ -d "$(top_srcdir)/scripts/git" ]; then \
- shellcheck $(top_srcdir)/scripts/git/*.git-hook; \
- fi; \
- fi
+ $(top_srcdir)/scripts/maint/checkShellScripts.sh
check-local: check-spaces check-changes check-includes check-best-practices shellcheck
@@ -322,7 +309,7 @@ need-stem-path:
fi
test-stem: need-stem-path $(TESTING_TOR_BINARY)
- @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --integ --log notice --target RUN_ALL;
+ @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --integ --test control.controller --test control.base_controller --test process --log notice;
test-stem-full: need-stem-path $(TESTING_TOR_BINARY)
@$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor "$(TESTING_TOR_BINARY)" --all --log notice --target RUN_ALL,ONLINE -v;