summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 24 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 08cb8e3e7e..58ff9fb3e8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,6 +38,7 @@ include contrib/include.am
EXTRA_DIST+= \
ChangeLog \
+ CONTRIBUTING \
INSTALL \
LICENSE \
Makefile.nmake \
@@ -51,14 +52,14 @@ AM_ETAGSFLAGS=--regex='{c}/MOCK_IMPL([^,]+,\W*\([a-zA-Z0-9_]+\)\W*,/\1/s'
if COVERAGE_ENABLED
TEST_CFLAGS=-fno-inline -fprofile-arcs -ftest-coverage
if DISABLE_ASSERTS_IN_UNIT_TESTS
-TEST_CPPFLAGS=-DTOR_UNIT_TESTS -DTOR_COVERAGE -DDISABLE_ASSERTS_IN_UNIT_TESTS
+TEST_CPPFLAGS=-DTOR_UNIT_TESTS -DTOR_COVERAGE -DDISABLE_ASSERTS_IN_UNIT_TESTS @TOR_MODULES_ALL_ENABLED@
else
-TEST_CPPFLAGS=-DTOR_UNIT_TESTS -DTOR_COVERAGE
+TEST_CPPFLAGS=-DTOR_UNIT_TESTS -DTOR_COVERAGE @TOR_MODULES_ALL_ENABLED@
endif
TEST_NETWORK_FLAGS=--coverage --hs-multi-client 1
else
TEST_CFLAGS=
-TEST_CPPFLAGS=-DTOR_UNIT_TESTS
+TEST_CPPFLAGS=-DTOR_UNIT_TESTS @TOR_MODULES_ALL_ENABLED@
TEST_NETWORK_FLAGS=--hs-multi-client 1
endif
TEST_NETWORK_WARNING_FLAGS=--quiet --only-warnings
@@ -217,6 +218,26 @@ check-logs:
$(top_srcdir)/scripts/maint/checkLogs.pl \
$(top_srcdir)/src/*/*.[ch] | sort -n
+.PHONY: check-typos
+check-typos:
+ @if test -x "`which misspell 2>&1;true`"; then \
+ echo "Checking for Typos ..."; \
+ (misspell \
+ $(top_srcdir)/src/[^e]*/*.[ch] \
+ $(top_srcdir)/doc \
+ $(top_srcdir)/contrib \
+ $(top_srcdir)/scripts \
+ $(top_srcdir)/README \
+ $(top_srcdir)/ChangeLog \
+ $(top_srcdir)/INSTALL \
+ $(top_srcdir)/ReleaseNotes \
+ $(top_srcdir)/LICENSE); \
+ else \
+ echo "Tor can use misspell to check for typos."; \
+ echo "It seems that you don't have misspell installed."; \
+ echo "You can install the latest version of misspell here: https://github.com/client9/misspell#install"; \
+ fi
+
.PHONY: check-changes
check-changes:
if USEPYTHON