summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 9 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index fe2479a642..c74b0e30a8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,9 +25,9 @@ AM_CFLAGS=@TOR_SYSTEMD_CFLAGS@ @CFLAGS_BUGTRAP@ @TOR_LZMA_CFLAGS@ @TOR_ZSTD_CFLA
SHELL=@SHELL@
if COVERAGE_ENABLED
-TESTING_TOR_BINARY=$(top_builddir)/src/or/tor-cov$(EXEEXT)
+TESTING_TOR_BINARY=$(top_builddir)/src/app/tor-cov$(EXEEXT)
else
-TESTING_TOR_BINARY=$(top_builddir)/src/or/tor$(EXEEXT)
+TESTING_TOR_BINARY=$(top_builddir)/src/app/tor$(EXEEXT)
endif
if USE_RUST
@@ -40,7 +40,6 @@ endif
# "Common" libraries used to link tor's utility code.
TOR_UTIL_LIBS = \
- src/common/libor.a \
src/lib/libtor-process.a \
src/lib/libtor-time.a \
src/lib/libtor-fs.a \
@@ -68,7 +67,6 @@ TOR_UTIL_LIBS = \
# Variants of the above for linking the testing variant of tor (for coverage
# and tests)
TOR_UTIL_TESTING_LIBS = \
- src/common/libor-testing.a \
src/lib/libtor-process-testing.a \
src/lib/libtor-time-testing.a \
src/lib/libtor-fs-testing.a \
@@ -110,22 +108,22 @@ TOR_CRYPTO_TESTING_LIBS = \
# All static libraries used to link tor.
TOR_INTERNAL_LIBS = \
- src/or/libtor-app.a \
+ src/core/libtor-app.a \
src/lib/libtor-compress.a \
+ src/lib/libtor-evloop.a \
$(TOR_CRYPTO_LIBS) \
$(TOR_UTIL_LIBS) \
- src/common/libor-event.a \
src/trunnel/libor-trunnel.a \
src/lib/libtor-trace.a
# Variants of the above for linking the testing variant of tor (for coverage
# and tests)
TOR_INTERNAL_TESTING_LIBS = \
- src/or/libtor-app-testing.a \
+ src/core/libtor-app-testing.a \
src/lib/libtor-compress-testing.a \
+ src/lib/libtor-evloop-testing.a \
$(TOR_CRYPTO_TESTING_LIBS) \
$(TOR_UTIL_TESTING_LIBS) \
- src/common/libor-event-testing.a \
src/trunnel/libor-trunnel-testing.a \
src/lib/libtor-trace.a
@@ -304,10 +302,10 @@ coverage-html-full: all
check-spaces:
if USE_PERL
$(PERL) $(top_srcdir)/scripts/maint/checkSpace.pl -C \
- $(top_srcdir)/src/common/*.[ch] \
$(top_srcdir)/src/lib/*/*.[ch] \
- $(top_srcdir)/src/or/*.[ch] \
- $(top_srcdir)/src/or/*/*.[ch] \
+ $(top_srcdir)/src/core/*/*.[ch] \
+ $(top_srcdir)/src/feature/*/*.[ch] \
+ $(top_srcdir)/src/app/*/*.[ch] \
$(top_srcdir)/src/test/*.[ch] \
$(top_srcdir)/src/test/*/*.[ch] \
$(top_srcdir)/src/tools/*.[ch]