summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 155b2557e5..8502682ca0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,3 +9,13 @@ EXTRA_DIST = INSTALL README AUTHORS LICENSE ChangeLog
#install-data-local:
# $(INSTALL) -m 755 -d $(LOCALSTATEDIR)/lib/tor
+
+dist-rpm: dist
+ rm -rf /tmp/tor-rpm-build
+ mkdir /tmp/tor-rpm-build
+ for subdir in BUILD RPMS SOURCES SPECS SRPMS; do \
+ mkdir /tmp/tor-rpm-build/$$subdir; \
+ done
+ cp tor-$(VERSION).tar.gz /tmp/tor-rpm-build/SOURCES
+ rpmbuild -ba --define '_topdir /tmp/tor-rpm-build' contrib/tor.spec
+ mv /tmp/tor-rpm-build/*RPMS/* .