summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 43ae161369..af3746e77a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,3 @@
-# $Id$
# Copyright (c) 2001-2004, Roger Dingledine
# Copyright (c) 2004-2006, Roger Dingledine, Nick Mathewson
# Copyright (c) 2007-2010, The Tor Project, Inc.
@@ -11,7 +10,7 @@ SUBDIRS = src doc contrib
DIST_SUBDIRS = src doc contrib
-EXTRA_DIST = INSTALL README AUTHORS LICENSE ChangeLog \
+EXTRA_DIST = INSTALL README LICENSE ChangeLog \
ReleaseNotes tor.spec tor.spec.in
#install-data-local:
@@ -59,15 +58,17 @@ dist: check
doxygen:
doxygen && cd doc/doxygen/latex && make
-test:
- ./src/or/test
+test: all
+ ./src/test/test
-# Avoid strlcpy.c, strlcat.c, tree.h
+# Avoid strlcpy.c, strlcat.c, aes.c, OpenBSD_malloc_Linux.c, sha256.c,
+# eventdns.[hc], tinytest.[ch]
check-spaces:
./contrib/checkSpace.pl -C \
src/common/*.h \
src/common/[^asO]*.c src/common/address.c \
- src/or/[^et]*.[ch] src/or/t*.c src/or/eventdns_tor.h
+ src/or/[^et]*.[ch] src/or/t*.c src/or/eventdns_tor.h \
+ src/test/test*.[ch]
check-docs:
./contrib/checkOptionDocs.pl